Excel Funktionen

Aus Gargi.org
Wechseln zu: Navigation, Suche


WENN

=WENN(Kriterium;Ergebnis;Sonst)

Wenn also ein Ereignis wahr ist, dann tritt das Ergebnis ein, ansonsten etwas anderes.

Beispiel:

=WENN(A1 > 5;A1+A3;"der Wert ist zu klein")


UND (in Kombination mit WENN)

=WENN(UND(Kriterium1;Kriterium2;...);Ergebnis;Sons t)

Wenn also mehrere Ereignisse wahr sind, dann tritt das Ergebnis ein, ansonsten etwas anderes.

Beispiel:

=WENN(UND(A1 > 5; B2 = "tätig");A1+A3;"Kein Treffer gefunden")


SUMMEWENN

=SUMMEWENN(Suchbereich;Kriterium;Summe aus den Treffern)

In einem bestimmten Tabellenbereich werden alle Elemente mit einem bestimmten Kriterium gesucht. Die damit verbunden bestimmten Zahlenwerte werden dann zusammengezählt. Also alle Erlöse aus einem bestimmten Artikel, alle Stunden aus einem bestimmten Arbeitstag der Woche etc.

Beispiel:

=SUMMEWENN(A1:A10;> 1200;C1:C10)

(Als Kriterium kann man auch durchaus einzelne Zellen miteinander abgleichen, also nur dort zusammenzählen, wo ein bestimmter Zellenwert mit einem anderen übereinstimmt. Also beliebig ausbaubar)

SUMMEWENNS

=SUMMEWENNS(Summe in einem Bereich; Suchbereich1; Kriterium1; Suchbereich2; Kriterium2;...)

In einer Tabelle sollen mehrere Kriterien erfüllt (wahr) sein und dann aus allen Treffern die Summe gebildet werden.

Beispiel:

=SUMMEWENNS(A1:A10;B1:B10;> 1200;C1:C10;"Juli")

Summe aus alles was größer 1200 und im Juli war. (Als Kriterium kann man auch durchaus einzelne Zellen miteinander abgleichen, also nur dort zusammenzählen, wo ein bestimmter Zellenwert mit einem anderen übereinstimmt. Also beliebig ausbaubar)


SVERWEIS

=SVERWEIS(Kriterium;Suchbereich(Matrix);Abstand zur Suchzelle;FALSCH)

Ähnlich wie SUMMEWENN, nimmt man aber gerne, wenn man einen Treffer innerhalb einer Tabelle sucht.

Beispiel:

=SVERWEIS(Müller;A:G;3;FALSCH)

Sucht in den Spalten A bis G einen Müller und liefert den um 3 Zellen versetzten Ergebniswert (von der Trefferzelle aus gerechnet). Für gewöhnlich nimmt man dann hier keinen festen Suchwert in die Formel (also den Müller), sondern einen flexiblen Wert, den man eventuell über ein Dropdown auswählt und das Dropdown ein Ergebnis in einer bestimmten Zelle liefert. Diese Zelle hinterlegt man dann als Suchkriterium beispielsweise.


HEUTE

=HEUTE()

Zeigt das aktuelle Datum an.

Beispiel:

=HEUTE()

Zeigt das aktuelle Jahr an:

Beispiel:

=JAHR(HEUTE())

Zeigt das aktuelle Monat an:

Beispiel:

=MONAT(HEUTE())

Zeigt den aktuellen Tag an:

Beispiel:

TAG(HEUTE())


DATEDIF

=DATEDIF(StartDatum;EndDatum;"d/m/y")

Geniale Funktion! Diese berechnet die Differenz aus zwei Daten (ja, das ist der Plural von Datum ) Hierbei kann man am Ende der Funktion festlegen, was als Differenz ausgegeben wird: Die Tage (d) , die Monate (m) oder die Jahre (Y).

Beispiel:

=DATEDIF(A1;A2;"d")

Berechnet die Differenz in Tagen aus dem Startdatum in Zelle A1 zum Enddatum aus Zelle A2. Folgende Funktion beispielsweise berechnet die Anzahl an Tage, die man bereits gelebt oder auch verballert hat (gemessen am aktuellen Datum):

=DATEDIF(E3;HEUTE();"d")

Auf E3 dann eben das Geburtsdatum eingeben. Carpe diem!


Postleitzahlen aus einem String in einer Zelle extrahieren

=TEXT(VERWEIS(9^9;1*TEIL(WECHSELN(A1;" ";"#")&"#";SPALTE(1:1);5));"00000")


Postleitzahlen reparieren (vorangestellte 0 fehlt, Zelle wird als Zahl interpretiert)

=TEXT(A1;"00000")

Ergebnis dann als Wert überkopieren


(VBA) Registerblätter als Datei einzeln speichern

Sub aufteilen()
For i = 1 To ActiveWorkbook.Sheets.Count
Blatti = Sheets(i).Name
Sheets(i).Copy
ActiveWorkbook.SaveAs Blatti
ActiveWorkbook.Close
Next i
End Sub


(VBA) Leerzeichen in zwei Spalten (A und D) entfernen. Gezählt wird nach der Spalte B

Sub Leerzeichen_entfernen()
  
Dim BereichL As Range 'übernehmen für Leerzeichen entfernen
Dim ZelleL As Object 'übernehmen für Leerzeichen entfernen
Dim lgLZ As Long 'Zeilen zählen

'Zeilen zählen
lgLZ = Tabelle1.Cells(Rows.Count, 2).End(xlUp).Row
  
'Leerzeichen entfernen
Set BereichL = Range(Cells(1, 1), Cells(lgLZ, 1))
For Each ZelleL In BereichL
ZelleL.Value = RTrim(ZelleL.Value) 'bereinigt um Leerzeichen am Ende
Next ZelleL
  
'Leerzeichen entfernen
Set BereichL = Range(Cells(1, 4), Cells(lgLZ, 4))
For Each ZelleL In BereichL
ZelleL.Value = RTrim(ZelleL.Value) 'bereinigt um Leerzeichen am Ende
Next ZelleL


End Sub


(VBA) Ab Zeile 2 Zeile gelb Färben wenn Werte in zwei unterschiedliche Spalten nicht leer

Sub Nichtleere_faerben()
Dim i, lz As Long

'Zeilen nach Spalte B zählen
lz = Cells(Rows.Count, 2).End(xlUp).Row

'Ab zweite Zeile Werte in Spalte A und E suchen, bis Spalte G Treffer färben
    Application.ScreenUpdating = False
    For i = 2 To lz
        If (Cells(i, 1).Value <> "") Or (Cells(i, 5).Value <> "") Then
            Range(Cells(i, 1), Cells(i, 7)).Interior.ColorIndex = 6 'ColorIndex 6 ist gelb
        End If
    Next
    Application.ScreenUpdating = True
    
End Sub